Dashboard
Incident Report for Teliax
Resolved
Services have been restored at of 3:04 PM MTN. We will continue to monitor for any additional issues.
Posted over 1 year ago. Jun 20, 2017 - 14:18 MDT
Investigating
We are currently experiencing issues with atl.teliax.net, lax.teliax.net, and nyc.teliax.net. We are investigating the issue and will provide updates as they become available.
Posted over 1 year ago. Jun 20, 2017 - 13:37 MDT