Calling Issue On IVY
Incident Report for Teliax
Resolved
Calls Completing on IVY at this time. Investigating causes and future response.
Posted almost 2 years ago. Jul 25, 2016 - 12:54 MDT
Investigating
We are currently investigating a issue that affects call completion on IVY .We will update with more information very soon..ETA 5 minutes.
Posted almost 2 years ago. Jul 25, 2016 - 12:48 MDT